Pixel 6 and Galaxy S22 affected by major new Linux kernel vulnerability

Ryne Hager

Android Police


Pixel 6 and Galaxy S22 affected by major new Linux kernel vulnerability

A seemingly major vulnerability has been discovered by security researcher and Northwestern PhD student Zhenpeng Lin, affecting the kernel on the Pixel 6 and 6 Pro and other Android devices running Linux kernel versions based on 5.10 like the Galaxy S22 series. Precise details for how the vulnerability works have not yet been published, but the researcher claims that it can enable arbitrary read and write, privilege escalation, and disable SELinux security protections — in short, this is a biggie. The researcher has verified to Android Police that Google was not informed of the vulnerability before its demonstration on Twitter.

Continue Reading